X C o n t e s t   2 0 0 9


[Thread] x86_64 for linux w/firefox 3 ?

x86_64 for linux w/firefox 3 ?
Author: mfournier (+0) (-0) | Posted: 02.09.2008 * 22:47

Hello,

Thanks for this great tool !

It would be really convenient to have support for 64 bit linux. I reckon most linux users with reasonably recent computers will be using 64 bit architectures nowdays.

I have such a system and would be glad to help/test. Let me know !

Marc

24 posts
views: 3963
  • 1 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 12.09.2008 * 12:39

    I will get to it within 2 weeks. I will be preparing new versions for all the platforms, this one is planned as well. I will contact you.

  • 2 RE: x86_64 for linux w/firefox 3 ?
    Author: mfournier (+0) (-0) | Posted: 17.09.2008 * 20:49

    Thanks for your answer and for all the work ! I'm looking forward to this new version :-)

  • 3 RE: x86_64 for linux w/firefox 3 ?
    Author: TobiasB (+0) (-0) | Posted: 18.12.2008 * 08:39

    Hi Ondřej,

    first of all: Thanks for the great program!!!

    Any news on the 64bit linux version?

    Thanks and best regards,

    Tobias.

  • 4 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 03.01.2009 * 07:28

    Do you have a rough estimate when the 64bit Linux version will be finished? Any Betas yet?

    Christian

  • 5 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 04.01.2009 * 19:55

    I have access to some 64-bit machines, will take a look next week.

  • 6 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 05.01.2009 * 15:53

    Beta version for x86_64 linux is available at http://paragliding.iglu.cz/download/gipsy/gipsy1.4amd.xpi

    I did not test it with real GPS as it was developed on vmware machine. It would hopefully work with Aircotec, I am not quite sure about the Garmin, if there is anyone to test it, it would be great.

  • 7 RE: x86_64 for linux w/firefox 3 ?
    Author: vaca (+0) (-0) | Posted: 06.01.2009 * 07:30

    Error loading GPS component

    This error message means that an error occured while loading a platform-dependent GPS component.

    This can happen when:

    * Your platform is unsupported. Currently supported platform is Linux-i386 with libstdc++.so.6 compiled binary and Windows platform.

    * You share your profile with Windows version of Firefox. In such case run 'firefox -profilemanager', create new profile and install the extension.

    * You are using Windows XP Home system without msvcrt80.dll library. Install the following package: Microsoft Visual C++ 2005 Redistributable Package (x86), then uninstall GiPSy and install it

    Fedora 10 x86_64 firefox 3.0.5

  • 8 RE: x86_64 for linux w/firefox 3 ?
    Author: TobiasB (+0) (-0) | Posted: 10.01.2009 * 20:26

    Hi Ondřej,

    tested with Kubuntu 8.04 AMD64 and Garmin eTrex Vista HCx (USB).

    Works great!

    The only thing I could not test was uploading a flight to xcontest.org (I only had old flight data on the GPS which led to the correct error message from the xcontest server ("past deadline")).

    Thanks a lot!!!

  • 9 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 11.01.2009 * 15:56

    Thanks Tobias. Vaca, that seems to be some problem with Fedora, I will install it next week and try to find out the problem.

  • 10 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 30.01.2009 * 15:39

    Ondrej,

    I tried the above Beta and got the same error message as Vaca.

    I'm using Fedora Core 8 with Firefox/3.0.5 x86_64; en-US; (Remi/fc8 RPM).

    Regards,

    Christian

  • 11 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 03.02.2009 * 12:04
  • 12 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 03.02.2009 * 19:32

    Just tried it out but I still get the same error message. I even tried creating a new Firefox Profile as a root user - just to see, if it is a rights issue - but no success.

    Is there a way of debugging the extension or getting some sort of error output to track down the problem?

    Regards,

    Christian

  • 13 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 03.02.2009 * 19:40

    Can you try to uninstall gipsy and then install it again?

    Probably the best way would be finding the file 'gipsy.so' (should be somewhere in ~/.mozilla/firefox/..../plugins/gipsy@pgweb.cz/components) and running 'ldd gipsy.so' and sending me the output.

  • 14 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 03.02.2009 * 20:01

    > Can you try to uninstall gipsy and then install it again?

    I did that right at the start and after it didn't work, I tried creating a new profile installed gipsy.xpi again, which didn't work as well. Then I tried the same thing as root - to no avail.

    Here is the output of ldd gipsy.so

    [root@chabich components]# ls -ail

    total 2892

    37945439 drwxr-xr-x 2 chabich chabich 4096 2009-02-03 20:08 .

    37945401 drwxr-xr-x 3 chabich chabich 4096 2009-02-03 20:08 ..

    37945456 -rwxr-xr-x 1 chabich chabich 2947128 2009-02-03 12:56 gipsy.so

    [root@chabich components]# ldd gipsy.so

    ./gipsy.so: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./gipsy.so)

    linux-vdso.so.1 => (0x00007fff09bff000)

    libxul.so => not found

    libxpcom.so => not found

    libplds4.so => /usr/lib64/libplds4.so (0x00000000005e0000)

    libplc4.so => /usr/lib64/libplc4.so (0x00000000007e3000)

    libnspr4.so => /usr/lib64/libnspr4.so (0x00000000009e7000)

    libpthread.so.0 => /lib64/libpthread.so.0 (0x0000000000c21000)

    libdl.so.2 => /lib64/libdl.so.2 (0x0000000000e3c000)

    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x000000000b5d7000)

    libm.so.6 => /lib64/libm.so.6 (0x0000000001040000)

    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000000012c3000)

    libc.so.6 => /lib64/libc.so.6 (0x00000000014d1000)

    /lib64/ld-linux-x86-64.so.2 (0x0000003725e00000)

    [root@chabich components]#

  • 15 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 03.02.2009 * 20:57

    ... oh and I have the following version of libstdc++ installed (both 32bit and 64bit)

    [root@chabich components]# rpm -qa | grep libstdc

    libstdc++-devel-4.1.2-33

    compat-libstdc++-33-3.2.3-62

    compat-libstdc++-296-2.96-139

    compat-libstdc++-33-3.2.3-62

    libstdc++-4.1.2-33

    libstdc++-4.1.2-33

    [root@chabich components]#

  • 16 RE: x86_64 for linux w/firefox 3 ?
    Author: vaca (+0) (-0) | Posted: 03.02.2009 * 21:10

    Dík už to šlape.

  • 17 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 04.02.2009 * 08:46

    Chabich, the problem is that your Fedora has old libraries. There are 2 options - either you upgrade or I will try to compile it specifically for your OS.

  • 18 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 04.02.2009 * 10:36

    Upgrading the whole server to run a firefox plugin is a bit of an overkill. Also, most Linux users do not run a bleeding-edge Fedora 10 or similar. RHEL and Suse libraries for example are usually 2-3 Fedora Versions 'behind'.

    Would it be possible to compile a version with 'older' libraries?

    Thanks a lot for all your help!

    Christian

  • 19 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 04.02.2009 * 12:21

    I am just in the process of installing the Fedora 8 distro...

  • 20 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 04.02.2009 * 14:17

    >I am just in the process of installing the Fedora 8 distro...

    You are a STAR!!

  • 21 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 04.02.2009 * 15:09

    Same URL, I compiled it for Fedora, should work.

  • 22 RE: x86_64 for linux w/firefox 3 ?
    Author: chabich (+0) (-0) | Posted: 04.02.2009 * 15:41

    ... bloody excellent!! Works a treat! This version should now work with all newer versions of the libraries as well, is that correct?

    Thanks again!

    Christian

  • 23 RE: x86_64 for linux w/firefox 3 ?
    Author: ondrap (+33) (-2) | Posted: 04.02.2009 * 22:41

    Yes, I tried it in the new Ubuntu and it worked.

  • 24 RE: x86_64 for linux w/firefox 3.5 ?
    Author: chabich (+0) (-0) | Posted: 14.06.2009 * 17:12

    Ondrap,

    at the risk of sounding very cheeky, I wanted to ask, if you by any chance already tried to compile a version for for x86_64 linux w/firefox 3.5?

    I will gladly act as your 'guinea-pig' ... ;-) ... especially if the first compilation works as bugfree as the first version further up in the thread.

    Regards,

    Christian

    Regards,

    Christian

Only logged users are allowed to add new posts.





Sections: